Какую банку следует включить для использования пакета javax.persistence в приложении на спящем режиме?

Можно ли взять его из проекта Glassfish (glassfish-persistence-api) или, может быть, есть спящий барабан?

4b9b3361

Если вы разрабатываете систему OSGi, я бы порекомендовал вам загрузить версию "bundlefied" из Springsource Enterprise Bundle Repository.

В противном случае его нормально использовать обычный jar файл, содержащий пакет javax.persistence

11
ответ дан 10 апр. '09 в 22:27
источник

Если вы используете maven, добавление ниже зависимости должно работать

<dependency>
    <groupId>javax.persistence</groupId>
    <artifactId>persistence-api</artifactId>
    <version>1.0</version>
</dependency>
13
ответ дан 24 авг. '11 в 14:43
источник

Вы можете использовать ejb3-persistence.jar, который связан с гибернацией. Эта банка включает только пакет javax.persistence.

12
ответ дан 28 окт. '09 в 15:27
источник

В последнем и максимальном спящем режиме я смог разрешить зависимость, включив hibernate-jpa-2.0-api-1.0.0.Final.jar в каталог lib/jpa. Я не нашел jjb-persistence jar в самой последней загрузке.

8
ответ дан 07 апр. '11 в 20:07
источник

hibernate.jar и hibernate-entitymanager.jar содержат только пакеты org.hibernate. *. Поэтому вы должны взять его из проекта Glassfish.

4
ответ дан 10 апр. '09 в 15:39
источник

Для JPA 2.1 пакет javax.persistence можно найти здесь:

<dependency>
   <groupId>org.hibernate.javax.persistence</groupId>
   <artifactId>hibernate-jpa-2.1-api</artifactId>
   <version>1.0.0.Final</version>
</dependency>

Смотрите: hibernate-jpa-2.1-api на Maven Central Кажется, что шаблон изменяет имя артефакта, когда изменяется версия JPA. Если это будет продолжаться, новые версии можно ожидать в Maven Central здесь: Hibernate JPA версии

Вышеупомянутый JPA 2.1 APi может использоваться в сочетании с Hibernate 4.3.7, в частности:

<dependency>
   <groupId>org.hibernate</groupId>
   <artifactId>hibernate-entitymanager</artifactId>
   <version>4.3.7.Final</version>
</dependency>
3
ответ дан 04 дек. '14 в 21:35
источник

В общем, я согласен с приведенными выше ответами, которые рекомендуют добавить зависимость от maven, но я предпочитаю следующее решение.

Добавьте зависимость с классами API для полного профиля JavaEE:

<properties>
    <javaee-api.version>7.0</javaee-api.version>
    <hibernate-entitymanager.version>5.1.3.Final</hibernate-entitymanager.version>
</properties>

<depencies>
    <dependency>
        <groupId>javax</groupId>
        <artifactId>javaee-api</artifactId>
        <version>${javaee-api.version}</version>
        <scope>provided</scope>
    </dependency>
</dependencies>

Также добавьте зависимость с конкретным поставщиком JPA, например, antonycc:

<dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-entitymanager</artifactId>
    <version>${hibernate-entitymanager.version}</version>
</dependency>

Примечание <scope>provided</scope> в разделе зависимости API: это означает, что соответствующая банка не будет экспортироваться в артефакт lib/, но будет предоставлена ​​сервером приложений. Убедитесь, что ваш сервер приложений реализует указанную версию JavaEE API.

3
ответ дан 02 авг. '15 в 18:50
источник